How to fix Rebar3 detected a lock file from a newer version

I recently ran into an issue where adding ```hackney``` and running ```mix deps.compile``` would throw the following error: 

>===> Rebar3 detected a lock file from a newer version.It will be loaded in compatibility mode, but important information may be missing or lost. It is recommended to upgrade Rebar3.

Running ```mix local.rebar``` fixed my issue.

nickciolpan
06 Jul 2020